Just another IT- & Travel-Blog

Menü Schließen

Kategorie: Hardware & Geräte

Ubiquiti UniFi Controller Installation

Im folgenden Artikel beschreibe ich die saubere Installation der UniFi Controller Software als Service unter Windows Server 2019 mit AdoptOpenJDK.

Zur Vorbereitung alle nötigen Komponenten herunterladen:

  • UniFi Network Controller 5.x.y for Windows (Link)
  • AdoptOpenJDK Version 8, LTS, Hotspot (Link)
  • Apache Commons Daemon (Link)

Das Setup des Controllers als Windows Service wird durch die Architektur und die Verwendung von AdoptOpenJDK 64-Bit ein wenig erschwert.

  1. Problem: der von UniFi Service Controller (Apache Commons Daemon Service Runner) wird mit einer Service-Config ausgeliefert, die mit der 64-Bit JVM nicht automatisch zurechtkommt.
  2. Problem: die UniFi Setup-Routine installiert das Verzeichnis des Controllers im Benutzerprofil des ausführenden Users!

Der Support-Eintrag in der UniFi Knowledgebase ist dazu leider auch nur bedingt hilfreich: Run the Controller as Windows Service

Weiterlesen

Ubiquiti UniFi Controller SSL-Zertifikat

Wer den UniFi Controller nicht hinter einem Proxy betreiben will (oder kann) steht früher oder später vor der Herausforderung das mitgelieferte „self-signed“ SSL-Zertifikat zu ersetzen.

Meiner interne UniFi Umgebung läuft unter Windows und fordert über CertBot regelmäßig Let’s Encrypt SSL-Zertifikate an, die aus dem PFX-Archiv in den Java KeyStore des UniFi Controllers kopiert werden müssen. Als Werkzeug dient hier das Java „KeyTool“, welches vom JDK mitgeliefert wird.

Dazu wird der „Alias“ des Zertifikats im PFX-Archiv benötigt, der mit dem KeyTool ausgelesen werden kann:

keytool.exe -v -list -storetype pkcs12 -keystore <Pfad-zum-PFX> -storepass <PFX-Passwort> | findstr Alias

Anschließend kann das gewünschte Zertifikat aus dem PFX in den KeyStore kopiert werden (als KeyStore-Passwort muss das UniFi-Standardpasswort verwendet werden):

del .\keystore /Q

keytool.exe -importkeystore -srckeystore <Pfad-zum-PFX> -srcstorepass <PFX-Passwort> -destkeystore keystore -srcstoretype pkcs12 -deststoretype jks -deststorepass aircontrolenterprise -destkeypass aircontrolenterprise -destalias unifi -srcalias {<Cert-Alias (siehe oben)>}

Anschließend den UniFi Controller neu starten.

Windows Server core – Shell und Bitlocker

Windows Server

Windows Server Core hat keine grafische Oberfläche und wird daher primär remote oder mit PowerShell konfiguriert. Dazu macht es Sinn, PowerShell als Default Shell zu konfigurieren:

Set-ItemProperty -Path 'HKLM:\Software\Microsoft\Windows NT\CurrentVersion\WinLogon' -Name Shell -Value 'PowerShell.exe'

BitLocker aktivieren

Wenn das System außerhalb einer geschützten Umgebung läuft ist es außerdem empfehlenswert, die Daten mit BitLocker zu verschlüsseln.

Dazu BitLocker aktivieren…

Enable-BitLocker -MountPoint "C:" -UsedSpaceOnly -TpmProtector

… mit einem Recovery Passwort versehen…

Add-BitLockerKeyProtector -MountPoint "C:" -RecoveryPasswordProtector

… und dieses im Active Directory sichern:

$blv = Get-BitLockerVolume -MountPoint "C:"
Backup-BitLockerKeyProtector -MountPoint "C:" -KeyProtectorId $blv.KeyProtector[1].KeyProtectorId

Game of Drones

Gestern hatte ich erstmals Gelegenheit, an einer Drohne herumzuspielen. Genauer gesagt einer Beta65S mit TX02-Controller und einem SPI Receiver.

Game of Drones @ dataformers

Ein bisschen Rumspielen muss auch sein! Rahmenprogramm beim internen "dataPlauscherl" gestern – eine Whoop Racing Drohne. :D

Gepostet von dataformers am Freitag, 12. Juli 2019
Game of Drones bei dataformers

Die Drohne zu kalibrieren und in die Luft zu bekommen ist erst mal gar nicht so einfach. Es gibt dieselbe Drohne in verschiedenen Ausführungen – und sie mit unserem TX02-Controller zu koppeln war auch nicht selbsterklärend. Da die Beschreibung in der BetaFPV Knowledgebase veraltet ist hier kurz die Schritte, die ich durchgeführt habe…

Weiterlesen

Lenovo BIOS Settings und PowerShell

Beginnend mit den T/W/X/L x30er-Serien bietet Lenovo WMI-Klassen, um BIOS/UEFI-Einstellungen direkt aus dem Betriebssystem heraus zu modifizieren. Die Klassen befinden sich im Namespace „root\wmi“.

Alle BIOS-einstellungen auslesen

Um eine Liste aller BIOS-Einstellungen incl. der aktuellen Werte auszulesen wird die WMI-Klasse „Lenovo_BiosSettings“ verwendet. Zur besseren Lesbarkeit wird die Ausgabe leicht motifiziert und „,“ durch „=“ ersetzt.

Weiterlesen

Cisco NAT und PAT konfigurieren

PAT konfigurieren

Internen IP-Adressbereich in der Access Control List (ACL) „1“ definieren:

Router(config) #access-list 1 remarks Internes-Netzwerk Category=2
Router(config) #access-list 1 permit 192.168.1.0 0.0.0.255

Vorhandene Interfaces als „Innen“ (Inside) und „Außen“ (Outside) im Sinne von NAT definieren:

Router(config) #interface Vlan 1
Router(config-interface) #ip nat inside

Router(config)#interface FastEthernet0
Router(config-interface) #ip nat outside

„NAT Overload“ (=PAT) für alle „Inside“ Interfaces auf das „Outside“ Interface aktivieren:

Router(config) #ip nat inside source list 1 interface FastEthernet0 overload

Aktuelle NAT Verbindungen anzeigen

Router #show ip nat translations

Configuring DHCP on Cisco routers

Cisco Systems

Cisco Routers can be configured to act as DHCP server.

In the following example we’re configuring a DHCP pool called „company“ for the IP adress range 10.1.1.100 to 10.1.1.150 in a /24 subnet. (The example setup uses 10.1.1.254 as default gateway and DNS server.)

Weiterlesen

Cisco IOS little helper

Cisco Systems

A few commands to make life easier while configuring Cisco devices:

Synchronous logging

Normally the default logging will „interrupt“ typing at the console. This can be prevented with synchronous logging.

Switch(config) #line vty 0 4
Switch(config-line) #logging synchronous

It must be configured on all „lines“, eg. Console, Telnet, SSH.

Exec timeout

By default, configuration sessions will be terminated after being idle for 5 minutes. The timeout can be customized by using the „exec-timeout“ command:

Switch(config) #line vty 0 4
Switch(config-line) #exec-timeout MINUTES

As with synchronous logging, this setting has to be configured on all „lines“.

DNS resolution

For troubleshooting (eg. ping/traceroute) it can be very helpful to enable name resolution by configuring the correct DNS servers:

Switch(config) #ip name-server 8.8.8.8

Disable DNS-lookups

By default any Cisco device will try to resolve unknown commands (eg. typos) to a DNS name. This can be prevented with:

Switch(config) #no ip domain-lookup

HP Array Configuration Utility (CLI)

Hewlett-Packard

Erst kürzlich hatte ich das zweifelhafte Vergnügen, in einer Windows Server Core Installation auf einem HP ProLiant Server ein RAID Array (wieder) einzurichten.

Da das HP Array Configuration Utility (ACU) in der Kommandozeile (CLI) nicht gerade selbsterklärend ist habe ich für die nächste „Begegung“ kurzerhand mitgeschrieben:

Das Commandline Utility „hpacucli.exe“ liegt nach der Installation des HP Array Configuration Utilitys in folgendem Verzeichnis: <C:\Program Files\Compaq\Hpacucli\Bin\>.

Grundsätzlich kennt das ACU die „Variablen“ target und command und wird immer nach dem folgenden Schema aufgerufen:

<target> <command> [parameter=value]

Mit target kann alles Mögliche gemeint sein – ein Controller, ein Array, eine Disk oder eine Kombination aus diesen. Die command Variable gibt an, welche Aktion wir auf das „target“ ausführen möchten, zB. „create“, „delete“ oder „modify“.

Ein paar grundlegende Befehle:

#Array auslesen:
controller slot=<X> physicaldrive all show

#Neues Array anlegen:
controller slot=<X> create type=ld drives=1:5,1:6,1:7,1:8 raid=5

#Konfiguration der logischen Laufwerke für Controller X anzeigen:
controller slot=<X> ld all show

#Hot Spare Disk zu Array Y hinzufügen:
controller slot=<X> array <Y> add spares=allunassigned

Quelle:

Watchguard VPN Authentication via Microsoft NPS

Watchguard Technologies

Die VPN-Authentifizierung auf Watchguard Firewalls lässt sich sehr einfach zu einem Windows NPS (Network Policy Server) durchreichen:

Weiterlesen

Dell OMSA auf VMWare ESXi 4.x installieren

Dell

Das Dell Open Manage Server Administrator (OMSA) Installationspaket für Linux lässt sich auch unter VMWare ESXi 4.x installieren.

Benötigt wird dazu natürlich ein Admin/Wartungszugang zum ESXi Host. Ich gehe außerdem davon aus, dass die Konfiguration durch VMware nicht offiziell unterstützt wird und daher für Produktivumgebungen nur bedingt geeignet ist.

Weiterlesen